AA Linux Editor

Discussion in 'Wishlist' started by Tom, Feb 20, 2017.

  1. Tom

    Tom Member

    Joined:
    Dec 26, 2016
    Messages:
    9
    Likes Received:
    13
    Trophy Points:
    3
    Hi guys !

    I'm a very happy Linux (Linux Mint) user :) and I think I'm not the only one...
    It would be amazing to get the AA's editor fully compatible with Linux Ubuntu based !!
     
    Last edited: Feb 22, 2017
    Marcus Baw, UnnoTed, Luke and 2 others like this.
  2. Dave_5150

    Dave_5150 Senior Member

    Joined:
    Dec 20, 2016
    Messages:
    529
    Likes Received:
    210
    Trophy Points:
    43
    Marcus Baw likes this.
  3. Tom

    Tom Member

    Joined:
    Dec 26, 2016
    Messages:
    9
    Likes Received:
    13
    Trophy Points:
    3
    Yes ! WIth Wine, I can launch the editor but I still get the same message : "Please connect Amplifire". Whatever I do, there's no connection at all :-(
    If I reboot my PC with Window$ (cause I have a dual boot), the editor works perfectly.
     
    Marcus Baw likes this.
  4. bioboy

    bioboy Well-Known Member

    Joined:
    Dec 20, 2016
    Messages:
    124
    Likes Received:
    73
    Trophy Points:
    28
    Occupation:
    working dead...
    Location:
    3feet under...
    Wine does not map usb devices without an appropriate driver
    try to map the usb as generic usb storage device, run "dmesg" in the terminal and check where is the reference to AA for example usb3 (must be a line referring to the input of the device), now go to Drives tab inside Wine Configuration menu and add a generic usb driver in the path (for this example /dev/usb3) hope this can help
     
    Last edited: Feb 21, 2017
    Marcus Baw likes this.
  5. Tom

    Tom Member

    Joined:
    Dec 26, 2016
    Messages:
    9
    Likes Received:
    13
    Trophy Points:
    3
    I tried your tip, but unfortunately it didn't work :-(
    Does it work for you ?
     
  6. bioboy

    bioboy Well-Known Member

    Joined:
    Dec 20, 2016
    Messages:
    124
    Likes Received:
    73
    Trophy Points:
    28
    Occupation:
    working dead...
    Location:
    3feet under...
    I'm actually on my mac but I'm sure that the problem is the driver (last wine version should recognize the usb device without any problem) later this night I will try to find the right driver with my linux pc (some generic IO driver should be fine for AA cause it's not an audio interface)
     
  7. Tom

    Tom Member

    Joined:
    Dec 26, 2016
    Messages:
    9
    Likes Received:
    13
    Trophy Points:
    3
    Thanks a lot !!
    I updated Wine 1.8 to 2.2 (staging) -> same result :-(
     
    Marcus Baw likes this.
  8. bioboy

    bioboy Well-Known Member

    Joined:
    Dec 20, 2016
    Messages:
    124
    Likes Received:
    73
    Trophy Points:
    28
    Occupation:
    working dead...
    Location:
    3feet under...
    Hey in the meantime you can turn around the problem by using a VM! ;)
     
  9. Flonka

    Flonka Active Member

    Joined:
    Apr 7, 2017
    Messages:
    35
    Likes Received:
    16
    Trophy Points:
    8
    Yeah, would be cool to be able to use some well known linux distro to run the editor in. Is this even remotely on some road map? :)

    EDIT: I was playing with the idea in my mind, of being able to for instance use a Raspberry PI, or similiar computer for this cause.
     
    Last edited: Apr 11, 2017
    Marcus Baw likes this.
  10. Pepi

    Pepi Well-Known Member

    Joined:
    Mar 20, 2017
    Messages:
    49
    Likes Received:
    16
    Trophy Points:
    8
    I've been using a VM for mine. I tried it with WINE and get an error without a log file :( All my other editors works with WINE. Zoom, ToneLab ....
     
  11. Teejoo

    Teejoo Member

    Joined:
    Mar 17, 2017
    Messages:
    19
    Likes Received:
    38
    Trophy Points:
    13
    Would the editor work on the Windows 10 version you can install on the Raspberry Pi?
     
  12. Dag Petersson

    Dag Petersson New Member

    Joined:
    Dec 21, 2016
    Messages:
    1
    Likes Received:
    1
    Trophy Points:
    1
    The Windows 10 version for Raspberry Pi is only for IoT (Internet of Things) devices and so on. It only have a limited version of Windows 10
     
    Marcus Baw likes this.
  13. aztekyi

    aztekyi Member

    Joined:
    Jun 19, 2017
    Messages:
    17
    Likes Received:
    7
    Trophy Points:
    3
    +1 for Linux support
     
    Marcus Baw likes this.
  14. floupcri

    floupcri New Member

    Joined:
    Feb 1, 2017
    Messages:
    1
    Likes Received:
    5
    Trophy Points:
    3
    Hi all !
    I got the editor working/connecting on wine, thanks to https://wiki.winehq.org/Hid
    This is on Arch linux with current wine package from official repo (2.13).Pedal is turned on and connected to a usb port on the computer.Editor is not running.

    Find which hidraw driver the amplifire is using :
    Code:
    $ dmesg | grep -i atomic
    [    3.098292] hid-generic 0003:04D8:003F.0005: hiddev0,hidraw2: USB HID v1.11 Device [Atomic Amps AmpliFire] on usb-0000:00:14.0-6/input0
    [  388.928847] hid-generic 0003:04D8:003F.0006: hiddev0,hidraw2: USB HID v1.11 Device [Atomic Amps AmpliFire] on usb-0000:00:14.0-6/input0
    
    Amplifire uses hidraw2 in my case.

    Change permissions to allow RW for users on /dev/hidraw2 (Change the hidraw number to the one you got on previous command) :
    Code:
    $ sudo chmod 666 /dev/hidraw2
    Done !
    Start editor now...
     
    Marcus Baw, Flonka, Dave_5150 and 2 others like this.
  15. Marcus Baw

    Marcus Baw Member

    Joined:
    Dec 28, 2017
    Messages:
    6
    Likes Received:
    6
    Trophy Points:
    3
    +1

    I also managed to get the editor working on Linux using the WINE Windows compatibility layer for Linux, on Linux Mint 18.3. As far as I can tell all functionality works perfectly.

    Some tips:

    1) ensure you are using a recent version of WINE - the standard version from the Xenial Ubuntu repositories (from which Linux Mint 18.3 is descended) was WINE 1.6 which did not work. I upgraded to a newer version (wine-2.21 (Staging)) using https://wiki.winehq.org/Ubuntu which did work once the permissions of hidraw were set as in the preceding post in this thread.

    2) the permissions settings `sudo chmod 666 /dev/hidrawX` don't seem to be persistent, so this step may need to be done each time you reconnect or reboot. Also, the Amplifire may connect on different HID devices at different times, so you may need to keep checking which device it's connected to using `dmesg | grep -i atomic`. It's possible to make these changes persistent using a udev rule, but I haven't quite sorted out how to do this and will post again when I've got a working udev rule.
     
    Mandy91 and Flonka like this.
  16. Flonka

    Flonka Active Member

    Joined:
    Apr 7, 2017
    Messages:
    35
    Likes Received:
    16
    Trophy Points:
    8
    Trying the VM way now, I find myself at a problem , getting the AA12 to be recognized as an USB device. Do i need to add some kind of USB driver support as other replies in this thread has mentioned?
     
    Marcus Baw likes this.
  17. Flonka

    Flonka Active Member

    Joined:
    Apr 7, 2017
    Messages:
    35
    Likes Received:
    16
    Trophy Points:
    8
    Following floupcri's and Marcus Baw's instructions , I got it running on WINE on Debian 8. Thanks guys. I installed staging version of wine, wine-2.21 (Staging).
     
    Marcus Baw and aleclee like this.
  18. Mandy91

    Mandy91 New Member

    Joined:
    Apr 27, 2018
    Messages:
    1
    Likes Received:
    1
    Trophy Points:
    3
    Thanks everyone for the great additions to get this working on Linux.

    I have used the following udev rule (in /etc/udev/rules.d/10-local.rules) to automatically set the permissions right when plugging in the Amplifire.

    BUS=='usb',ATTRS{manufacturer}=="Atomic Amps",KERNEL="hidraw[0-9]",MODE=0666


    Restart udev after adding the rule sudo systemctl restart udev to activate the rule.

    I have used this on Ubuntu 16.04 with Wine 3.0 and Amplifire Editor 5.0.3.1
     
    Flonka likes this.
  19. Flonka

    Flonka Active Member

    Joined:
    Apr 7, 2017
    Messages:
    35
    Likes Received:
    16
    Trophy Points:
    8

    Thanks, your post spurred me on to try and write an udev rule, which I had not done until now. Managed to get it working here with:

    SUBSYSTEMS=="usb", ATTRS{manufacturer}=="Atomic Amps", MODE="0666"

    http://www.reactivated.net/writing_udev_rules.html
     
  20. Marcus Baw

    Marcus Baw Member

    Joined:
    Dec 28, 2017
    Messages:
    6
    Likes Received:
    6
    Trophy Points:
    3
    Thanks for the udev rules @Flonka and @Mandy91

    Weirdly, considering I had this working a couple of weeks ago, I can't now get it to work on Linux. I had to use a Win10 VM to update the firmware just now, which has been successful, so I am on latest everything AFAICT, and I know the USB cable works etc!)

    Firmware: 5.0.3 on the AA3
    Editor 5.0.3.1 on Linux
    Wine 3.9 (staging)

    Setting the udev rules as above just doesn't work (the AA editor says 'Please Connect AmpliFIRE' despite restarting udev, reboots etc)

    I've tried checking which hidraw device the Amplifire has connected to (using dmesg | grep -i atomic ) and then manually setting the permissions on hidraw ( with sudo chmod 666 /dev/hidraw2 )

    Here's my current udev rule, where as you can see I also added a GROUP rule because listing /dev/hidraw* showed the device is owned by root, but I don't think it should matter.

    Code:
    $ cat /etc/udev/rules.d10-local.rules
    SUBSYSTEMS=="usb", ATTRS{manufacturer}=="Atomic Amps", MODE=="0666", GROUP=="plugdev"
    Code:
    $ ls -l /dev/hidraw*         
    crw-rw----+ 1 root root 246, 0 Jun  4 16:04 /dev/hidraw0
    crw-rw-rw-  1 root root 246, 1 Jun  4 17:57 /dev/hidraw1
    crw-rw----+ 1 root root 246, 2 Jun  4 16:04 /dev/hidraw2
    crw-rw----+ 1 root root 246, 3 Jun  4 16:04 /dev/hidraw3
    crw-------  1 root root 246, 4 Jun  4 16:04 /dev/hidraw4
    
    Weirdly, every time I unplug and replug the AA, it now adds a new device to dmesg, so I am now up to device 14... not sure if this is right, although if dmesg is a kind of log of kernel messages then maybe all the preceding ones are now only there because it's a log, rather than persistent devices/conflicting connections.
    Code:
    [ 6767.576442] usb 1-2: new full-speed USB device number 14 using xhci_hcd
    [ 6767.723230] usb 1-2: New USB device found, idVendor=04d8, idProduct=003f
    [ 6767.723232] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    [ 6767.723233] usb 1-2: Product: AmpliFire
    [ 6767.723234] usb 1-2: Manufacturer: Atomic Amps
    [ 6767.726519] hid-generic 0003:04D8:003F.0012: hiddev1,hidraw1: USB HID v1.11 Device [Atomic Amps AmpliFire] on usb-0000:00:14.0-2/input0
    
    Anyone any ideas?
     

Share This Page

Share