No answer from support

Discussion in 'Support' started by onemoreguitar, Dec 3, 2017.

  1. onemoreguitar

    onemoreguitar New Member

    Joined:
    Dec 3, 2017
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    So, I have 2 original CLRs, both dead, and I haven’t been able to get any answer from support. I have contacted them on the support email address as well as tagging them on Facebook and pm through messenger. Independent Music, where I purchased my CLRs, can’t get a response either. Andrew has helped all he can and always calls me back, but if he as the distributor can’t even get a response from Atomic...

    Both of my units have the same issue. The lights turn on, but they don’t make any noise. One of them will occasionally work for a few minutes on start up. I’ve been trying through Independent for a number of months now, but this is getting ridiculous. Amazing product, but useless support. Any help would be appreciated. I’m not overly impressed with having these 2 very expensive paper weights sitting around.
     
  2. Jace Nuzback

    Jace Nuzback Well-Known Member

    Joined:
    Apr 9, 2017
    Messages:
    128
    Likes Received:
    38
    Trophy Points:
    28
    Occupation:
    Product Specialist Atomic Amps
    Home Page:
    Hello,
    I'm sorry you've had so much trouble getting a hold of us.
    Please send an E-mail to support@atomicamps.com and copy me jnuzback@atomicamps.com
    We'll get you back in business.
    Again, Sorry for the troubles and support issues.
    Jace
     

Share This Page

Share