Sloooooow Backup/Restore

Discussion in 'Support & Bug Reporting' started by Ronwell, Jan 28, 2017.

  1. Ronwell

    Ronwell Member

    Joined:
    Jan 28, 2017
    Messages:
    16
    Likes Received:
    17
    Trophy Points:
    3
    Amplifire's backup/restore is really a time-consuming process (~ 7-10 minutes).

    The backups i've worked with are about 5mb.

    Why is it so slow? Can something be done about this in a future update?
     
    ConstantinosM likes this.
  2. Eric Raymond

    Eric Raymond Member

    Joined:
    Apr 8, 2019
    Messages:
    19
    Likes Received:
    2
    Trophy Points:
    3
    Yeah, this is amazingly slow. Seems like there's some tuning/buffering of I/O needed for JUCE? Is there any back and forth between the AA and the editor before the editor can dump the data?

    @Jace Nuzback , are there any setups that improve this (I'm on a Macbook Pro)?
     
    Last edited: May 17, 2019
  3. Jace Nuzback

    Jace Nuzback Senior Member

    Joined:
    Apr 9, 2017
    Messages:
    920
    Likes Received:
    625
    Trophy Points:
    93
    Occupation:
    Product Specialist Atomic Amps
    Home Page:
    Guys,
    I'm sorry to say that there is nothing that can be done about that.
    It is what it is.
    Jace
     
  4. Eric Raymond

    Eric Raymond Member

    Joined:
    Apr 8, 2019
    Messages:
    19
    Likes Received:
    2
    Trophy Points:
    3
    Would love to have a look at the editor source code. JUCE's support for zip files leaves something to be desired and there might be a workaround (if this is a software only issue).
     

Share This Page

Share