AA6 with TS latching toe switch: preset stepping up inadvertently

Discussion in 'Support & Bug Reporting' started by Kaweekrai, Aug 7, 2019.

  1. Kaweekrai

    Kaweekrai Member

    Joined:
    Nov 17, 2018
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hi, I need suggestion please.

    I use AA6 with Mission Engineering SP25L Pro Aero, which has 1 latching toe switch that I would like to use engaging Wah. I use Disaster Area Design's MidiBaby as an interface. Midibaby has Multi-jack input, which support TS and TRS. The SP25L requires TS for using it's latching switch, so I use TS jack connect SP25L to MidiBaby.

    At first, I found the problem that I have to press the latching switch twice to make the ON/OFF switching like,
    1st press - ON
    2nd press - nothing
    3rd press - OFF
    4th press - nothing

    After discussing with Disaster Area Design support service, I can make my SP25L engage Wah ON/OFF as it should be by set the behaviour of switch to be "Send PRESS messages on falling edge, RELEASE messages on rising edge".

    but... the problem is every time I press to turn Wah OFF, the preset of AA6 does step up for 1 step, like,
    1st press - Wah ON (preset 009)
    2nd press - Wah OFF (preset 010)
    3rd press - Wah ON (preset 010)
    4th press - wah OFF (preset 011)

    I'm not sure is this problem has to work with MidiBaby or AA6 and how to manage this.
     
  2. Kaweekrai

    Kaweekrai Member

    Joined:
    Nov 17, 2018
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    One funny thing, I just tried using TRS cable and the preset step up for 2 instead. o_O (preset009 -> 011 -> 013)
     
  3. JoeInOttawa

    JoeInOttawa Senior Member

    Joined:
    May 16, 2017
    Messages:
    267
    Likes Received:
    86
    Trophy Points:
    28
    Could be cabling, but it also sounds like it might be that something you;re plugged into is expecting a momentary (i.e., non-latching) switch on your pedal. Makes no sense, I know, but that's the behavior.
     
    Last edited: Aug 7, 2019
  4. Jace Nuzback

    Jace Nuzback Senior Member

    Joined:
    Apr 9, 2017
    Messages:
    1,089
    Likes Received:
    734
    Trophy Points:
    113
    Occupation:
    Product Specialist Atomic Amps
    Home Page:
    You might try just using the AUTO OFF mode for the wah instead:
    AUTO-OFF: This is a GLOBAL parameter. Enables the AUTO-OFF feature of the WAH effect . Most real WAHs have an on/off switch . Most expression pedals don’t . To solve this issue, we created an AUTO-OFF feature which can bypass your WAH effect automatically when the pedal is parked or inactive for a period of time .

    DISABLED: Turns off the AUTO-OFF feature, and your WAH is only manually controlled by the ENABLE parameter .

    INACTIVITY: Selects INACTIVITY AUTO-OFF mode . In this mode, the WAH will automatically turn off when the WAH PEDAL parameter is not changed more than the THRESHOLD amount during an interval of time specified by the TIMER parameter . (see THRESHOLD and TIMER parameters below) .

    PARKED: Selects PARKED AUTO-OFF mode . In this mode, the WAH will automatically turn off when the WAH PEDAL parameter is kept below the THRESHOLD amount during an interval of time specified by the TIMER parameter . (see THRESHOLD and TIMER parameters below) .
     
  5. Kaweekrai

    Kaweekrai Member

    Joined:
    Nov 17, 2018
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I'll ask the dealer if they have an M version stock for a try. Thank you.
     
  6. Kaweekrai

    Kaweekrai Member

    Joined:
    Nov 17, 2018
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1

    I had ever used the auto-off mode before and I find that it's not work for me, so I kept looking for something like this MI SP25L.

    As you are from Atomic team, may I ask if I choose the right toe switch? Does Atomic Amplifire work with Latching or Momentary? I can find that Kemper use Momentary but cannot find this information in AA6 manual.
     
  7. Jace Nuzback

    Jace Nuzback Senior Member

    Joined:
    Apr 9, 2017
    Messages:
    1,089
    Likes Received:
    734
    Trophy Points:
    113
    Occupation:
    Product Specialist Atomic Amps
    Home Page:
    The AmpliFIre doesn't accept external foot switches to turn on/off FX blocks.
    It will accept a MIDI CC command (CC19) to turn it on/off.
    DATA VALUES between 0 and 63 are interpreted as OFF, and DATA VALUES between 64 and 127 are interpreted as ON.
    The AUTO OFF function is really convenient and works great.
    I recommend giving it a second try.
    Jace
     
  8. Kaweekrai

    Kaweekrai Member

    Joined:
    Nov 17, 2018
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    The problem is solved as you and the support team from Disaster Area Design suggest. Now, I set the message to control #19 and set midi channel at Amplifire to be CH1 matching with midi send from interface.

    Thank you so much. I'm really appreciated your kindly help and also from other fellows.

    P.S. The auto-off mode is really great. Many of my friends (and many people worldwide) love this kind of function (in several brands). It's about me being used to the tradition way of using wah. :)
     

Share This Page

Share