MIDI CONTROL OF PITCHSHIFTER ENABLE FAILING

Discussion in 'Support & Bug Reporting' started by Paul Wilson, Jul 27, 2020.

  1. Paul Wilson

    Paul Wilson Member

    Joined:
    Mar 12, 2020
    Messages:
    19
    Likes Received:
    6
    Trophy Points:
    3
    Hi guys, anyone doing this successfully?

    I am using an MC6 MKII to send CC messages to enable and turn off modulation blocks, and all works perfectly except the Pitchshifter block which won't respond to the midi CC commands at all.

    I've tried setting different CC numbers in the Amplifire Editor, using different buttons on the MC6, controlling other mod blocks with the same MIDI preset (which works for othe blocks of course) but I cannot control the Pitchshifter bloc at all.

    Can someone try this out please?

    Thanks,

    PaulW
     
  2. Jace Nuzback

    Jace Nuzback Senior Member

    Joined:
    Apr 9, 2017
    Messages:
    1,339
    Likes Received:
    907
    Trophy Points:
    113
    Occupation:
    Product Specialist Atomic Amps
    Home Page:
    Paul,
    It's a known bug that is on the list for fixing.
    Sorry for the inconvenience.
     
  3. Paul Wilson

    Paul Wilson Member

    Joined:
    Mar 12, 2020
    Messages:
    19
    Likes Received:
    6
    Trophy Points:
    3
    Thanks for the quick reply. When is the bug fix release due? Something like this is such a small fix it shouldn't take long to combine with other minors so I hope it's not too long!

    I bought my AA6 earlier this year, and it's still under warranty, so I am sure you would agree it's reasonable to expect a fix fairly promptly.

    Thanks,

    PaulW
     
  4. Jace Nuzback

    Jace Nuzback Senior Member

    Joined:
    Apr 9, 2017
    Messages:
    1,339
    Likes Received:
    907
    Trophy Points:
    113
    Occupation:
    Product Specialist Atomic Amps
    Home Page:
    Paul,
    No ETA at this time.
    Hopefully we can get to it soon.
     
    Paul Wilson likes this.
  5. Paul Wilson

    Paul Wilson Member

    Joined:
    Mar 12, 2020
    Messages:
    19
    Likes Received:
    6
    Trophy Points:
    3
    Jace, (and anybody else affected) I found an undocumented feature that enables a get-around for AA6 users until the bug is fixed.

    Assign the Pitchshifter block to footswitch 7 (yes, 7!) on the AA6 using Preset Assign, then use a MIDI CC to press button 7 from your MIDI controller, in my case the MC6 MKII.

    Toggling indication on the controller is lost, but the effect toggles with the switch press just fine.

    PaulW
     
    Quadfire and Jace Nuzback like this.
  6. Jace Nuzback

    Jace Nuzback Senior Member

    Joined:
    Apr 9, 2017
    Messages:
    1,339
    Likes Received:
    907
    Trophy Points:
    113
    Occupation:
    Product Specialist Atomic Amps
    Home Page:
    That's a really clever work around!
    Bravo!
    Jace
     
    Paul Wilson likes this.
  7. Paul Wilson

    Paul Wilson Member

    Joined:
    Mar 12, 2020
    Messages:
    19
    Likes Received:
    6
    Trophy Points:
    3
    Just to clarify, I did manage to recover toggling indication on the MC6, by using the usual two toggling CC messages on the MIDI controller, conditional on toggle state, but with both messages sending an 'on' instruction, instead of the usual 'on' from toggle position 1, and 'off' from toggle position 2.
     

Share This Page

Share