Pitch shifter issue

Discussion in 'Support & Bug Reporting' started by Superseed, Feb 11, 2020.

  1. Superseed

    Superseed Member

    Joined:
    Jan 13, 2020
    Messages:
    20
    Likes Received:
    21
    Trophy Points:
    3
    I was hoping to ditch my Drop pedal and use the pitch shifter in my AA12 but it has this strange stuttering no matter how I set it. I tried changing from guitar input to effect input but still got the same results. Anyone else?
     
  2. Rob D

    Rob D Well-Known Member

    Joined:
    Jun 6, 2019
    Messages:
    49
    Likes Received:
    9
    Trophy Points:
    8
    Yah, was trying to do the same thing, but too much weird stuff going on, doesn't track well, really not good at all, unusable. Unfortunately. Was disappointed.
     
  3. Dagwin

    Dagwin Well-Known Member

    Joined:
    Sep 25, 2017
    Messages:
    154
    Likes Received:
    61
    Trophy Points:
    28
    Same here, tried to use the pitch shifter to downtune everything by 1 note in order to ditch the Digitech Drop form the pedal board.
    It is a no go, the Digitech Drop sounds a lot better.
    For things/effects other then downtuning the pitch shifter can be nice though.
     
  4. slateboy

    slateboy Senior Member

    Joined:
    Dec 20, 2016
    Messages:
    427
    Likes Received:
    228
    Trophy Points:
    43
    Location:
    uk
    Home Page:
  5. NelsonP

    NelsonP Senior Member

    Joined:
    Feb 11, 2017
    Messages:
    400
    Likes Received:
    190
    Trophy Points:
    43
    As far as I know the pitch shifter is only two note polyphonic.

    If you need more than that then you'll need am outboard pitch shifter. I use an EHX Pitchfork for this and it works very well.
     
  6. Scorstin

    Scorstin Member

    Joined:
    Jul 16, 2019
    Messages:
    10
    Likes Received:
    4
    Trophy Points:
    3
    I have the same issue, on Whammo setting as well as on the other two. The "stutter" seems to mostly occur when tuning up (it's almost constant then), but also happens on Whammo with the exp pedal heel down (which means no shift). It's random but makes me unable to play some faster riffs where I wanted to use whammy effect at the end of the phrase, for example, when it stutters mid-way through and throws me off balance...
    Any news on this issue please? I checked the original thread from slateboy and it was reported back in 2018. Otherwise I'll be forced to buy a dedicated pedal for that, and there goes my "all in one" solution :(
     

Share This Page

Share